Why does the print key not work?

After a while, I have tried to take a screenshot but oops, the key does not bring up the known KSnapshot tool any longer after an update to 16.10. What happened?

Kubuntu 16.10 replaces the old screen shot tool KSnapshot with Spectacle but does not change the keyboard setting accordingly. Under System Settings -> Shortcuts -> Custom Shortcuts the folder “Screenshots” must be developed to show an entry “Start Screenshot Tool”. The trigger for this entry must be set to be the print screen key. A dialog will prompt warning that the key is already assigned; it is assigned to KSnapshot; therefore ignore the warning.

Thank you for the help askubuntu.com.

Kubuntu 15.10

Thank you for the annoying “There is a new version” blabla and the update I did, which deleted my kdewallet.kwl file or substituted it with a new one, which resulted in the loss of all informatin. *sigh*
Yeah, I know the “no backup?!” comment but who expects deletion of files in home folder without backup/notification?!
Also telepathy has ceased to work because there is no chance to login to my xmpp account, where it is working flawlessly with pidgin. Guess I have to switch another time to another messenger… I want kopete back in working version!

Why Thunderbid does not let me change the default browser easily?

If I have already set my default browser to google-chrome in the system settings of my newly installed Kubuntu 15.04, why does Thunderbird not accept it?
Why do I have to manually type strings like xdg-mime query default x-scheme-handler/http to see that the default browser is still firefox.desktop?

So lets submit xdg-mime default google-chrome.desktop x-scheme-handler/http to update the default browser.

Thank you for pointing this out at http://kevinlocke.name/bits/2012/07/18/thunderbird-default-browser-linux/.

Previously, I had edited my Thunderbird setting while adding network.protocol-handler.app.http, my system settings with application/x-extension-html, application/x-extension-shtml, application/x-extension-xhtml, application/xhtml+xml, text/html and checked my mimeTypes.rdf in the profile folder.

Well, in the end it worked…

Podcast & Chromium

Ich wollte mir dann heute mal einen Podcast zu Gemüte führen und was passiert? Schwarzes Bild, mittig ein Play Button nebst Laufzeitanzeige und Lautstärkeregler aber es passiert nichts…

Ok Dr. Google hilft immer also kurz mal gesucht und siehe da, ich hab nicht das richtige (Standardinstallation von Chromium eben) Paket installiert:

sudo apt-get install chromium-codecs-ffmpeg-extra

anstatt:

chromium-codecs-ffmpeg

Zweiteres muss während der Installation von ersterem auch entfernt werden aber das geht in einem Abwasch. Nochmal den Browser neustarten und siehe da mein Podcast läuft.

view retail dvds on kubuntu

Wollte mir heute Abend eine DVD aufm Lappy anschauen, da mein Plasma außer Haus ist. Nuja nach längeren Lesezugriffsgeräuschen vom DVD Laufwerk kommt das wohlbekannte Kontextmenü, ob ich die DVD mounten möchte oder sonstige Anwendungen ausführen.

Fröhlich auf VLC geklickt und nach längerer Wartezeit öffnet sich selbiges auch aber nix vonwegen DVD abspielen…
Ok klick ich mal auf mounten und probiers nochmal aber immernoch Pustekuchen.
Eventuell hab ich irgendeine lib nicht installiert also Dr. Google fragen. Erstes Suchergebnis:

https://www.monsterli.ch/blog/2012/01/dvd-abspielen-unter-linux-ubuntu-kubuntu/

Also libdvdread4 hab ich bereits installiert aber irgendwo ist der Hinweis abhanden gekommen, dass ich noch folgende Zeile ausführen soll:

sudo sh /usr/share/doc/libdvdread4/install-css.sh

Danach hats, wie auf obiger Seite beschrieben, einwandfrei mit dem abspielen der original DVD geklappt. Und jetzt erfreue ich mich an The Lost Boys!

Microphone not working in Skype

Headset ans Lappy geklemmt und Skype gestartet für ein wenig Audiovisuelle Unterhaltung und siehe da: Ich sehe und höre mein Gegenüber aber dieses sieht mich nur, von Ton keine Spur.

Seltsame Geschichte aber gut vielleicht ist das Mic nicht richtig eingestellt. Irgendwo bei den Einstellungen dann das Mic gefunden und beim reinsprechen schlägt der Pegel nicht wirklich aus.

Testmodus von Skype gestartet und reingelabert. Beim anschließenden Testhören war Totenstille zu hören. Nach unzähligen Versuchen war ich dann doch etwas genervt und hab mir das Mic direkt vor den Mund geparkt und volle Lotte reingeplerrt. Siehe da der Pegel schlägt ja doch aus…

Was ist da los? Das Schlüsselwort ist PulseAudio Volume Control zur Steuerung des ach so tollen PulseAudio sound server.

Dazu sollte man sich einfach folgendes Paket installieren:

pavucontrol

Wer gern eine genauere Erläuterung möchte sollte hier nachlesen.

Mittlerweile nutze ich dann doch das integrierte Mic, denn das funktioniert jetzt auch gescheit.

Printing on a Windows shared Printer

Manchmal muss man doch das ein oder andere noch auf altmodisches Papier bannen und dazu eignet sich nichts besser als der im Netzwerk freigegebene Drucker.

Denkste! Sobald das gute Stück an einem Win7 Rechner hängt ist das drucken auf besagtem Drucker garnicht mehr so einfache, wenn man ein Linux System benutzt.

Ich seh zwar den Rechner unter Samba Shares aber das war dann das höchste der Gefühle, denn selbst eine Anmeldung als Administrator selbigen Rechners zeigt keine Datei-/Druckerfreigaben an.

Und warum ist das so?:

Um das Arbeiten im heimischen Netzwerk zu vereinfachen wurden die Netzwerkfunktionalität um eine Heimnetzgruppe erweitert. Womit sich jeder Windows 7 PC automatisch im Heimnetz selber einrichten soll.

Diese für Windows Netzwerke sehr praktische Funktion ist ziemlich unpraktikabel, wenn ich von meinem Kubuntu aus drucken will, weil es dort kein Heimnetzwerk gibt. Nicht einmal die Mitgliedschaft in der gleichen Arbeitsgruppe hilft.

Dr. Google hat natürlich wieder einmal Rat gewusst und mich mit folgendem Artikel beschenkt:

http://www.digital-eliteboard.com/showthread.php?162376-Windows-7-Ordner-oder-Laufwerk-freigeben-ohne-Kennwort

Die ersten beiden Berechtigungen (Reiter Freigabe/Sicherheit unter Eigenschaften des Druckers) hab ich so durchgeführt aber beim dritten Abschnitt hat mich meine leicht paranoide Ader wieder eingeholt und ich habe dann lieber einen weiteren User mit Passwort auf dem Windows PC angelegt, dessen einziger Sinn darin besteht Zugriff auf den Drucker zu erhalten.

Danach konnte ich dann auch endlich wieder der Papierindustrie meinen Beitrag zollen mit schönen Ausdrucken auf dem “Netzwerkdrucker”.

Aptitude/Muon not working

Was tun, wenn man weder per aptitude noch über den Muon Paketmanager Updates fahren kann und folgende Fehlermeldung erhält:

E: Paketdatei /var/lib/apt/lists/de.archive.ubuntu.com_ubuntu_dists_precise-backports_restricted_i18n_Translation-de konnte nicht verarbeitet werden (1)
E: Die Paketliste oder Statusdatei konnte nicht ausgewertet oder geöffnet werden.

Nach längerem Seek&Destroy Prozedere bin ich dann hier fündig geworden unter Step 5:

https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure

sudo grep -R proxy /etc/apt/*

sudo fuser -vvv /var/lib/dpkg/lock

cat /etc/lsb-release

uname -a

sudo rm /var/lib/apt/lists/lock

sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup

sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-bad

sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status

sudo mv /var/lib/dpkg/available /var/lib/dpkg/available-bad

sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available

sudo rm -rf /var/lib/dpkg/updates/*

sudo rm -rf /var/lib/apt/lists

sudo rm /var/cache/apt/*.bin

sudo mkdir /var/lib/apt/lists

sudo mkdir /var/lib/apt/lists/partial

LANG=C;sudo apt-get clean

LANG=C;sudo apt-get autoclean

LANG=C;sudo apt-get --purge autoremove

LANG=C;sudo apt-get update -o APT::Cache-Limit=100000000

sudo dpkg --configure -a

sudo dpkg --clear-avail

LANG=C;sudo apt-get -f install

LANG=C;sudo apt-get --fix-missing install

LANG=C;sudo apt-get update -o APT::Cache-Limit=100000000 && sudo apt-get dist-upgrade

find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;

fglrx and multiple displays

Heute wollte ich mir meinen zweiten Monitor auf der Arbeit einrichten ist ja alles ganz einfach…
Sofern man keine ATI Grafikkarte drin hat stimmt das auch, denn die Standard Bildschirmeinstellungen von Kubuntu kann man zwar nutzen um seinen zweiten Monitor anzusteuern aber irgendwie kopiert das nur das Bild von Monitor 1 auf Monitor 2.

Hmmm… ok da müsste es doch bestimmt auch irgendwas von ATI geben um die Monitoreinstellungen vorzunehmen? Klar gibt es und nennt sich fglrx aber leider ist der Launcher vom Admin-Interface verbuggt (das andre kann man zwar starten aber dann darf man sich nur alles ankucken und keine Modifikationen vornehmen) und fragt nach einem Benutzernamen und Passwort, welcher nicht die Eingabe des Rootaccounts akzeptiert!?

Unter folgendem Link kann man dann schön nachlesen, wie man per Shell doch noch das Admin-Interface aufrufen kann (amdcccle auf der Shell aufrufen):

http://wiki.ubuntuusers.de/Grafikkarten/ATI/fglrx/Konfiguration

Siehe da ich kann dann doch meine beiden Monitore konfigurieren. Der Tag ist gerettet!